Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!

本文记录刚接触Android开发搭建环境后新建工程各种可能的报错,并亲身经历漫长的解决过程(╥╯^╰╥),寻找各种偏方,避免大家采坑,希望能帮助到大家。

报错信息

      出错一:The import android.support cannot be resolved类型解决

      出错二:android.support.v4.app.TaskStackBuilder$SupportParentable cannot be resolved. 解决方法

      出错三:the file dx.jar was not loaded from the SDK folder! 解决(最后一步)

出错一:The import android.support cannot be resolved类型解决

如图,如果报The import android.support cannot be resolved或者android.support.v7.app.ActionBarActivity类似的错误。

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图

 

 解决方案 :缺少相关依赖包,这里提供亲测有效的库文件,需要导入android-support-v7-appcompat.jar 。

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(1)

 

 导入步骤:
(1)点击项目名,右键选择Properties,如图顺序:

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(2)

 

 (2)点击Add External JARs之后,选择刚刚下载的库文件android-support-v7-appcompat.jar ,进行导入如图:

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(3)

 

 点击Apple应用,然后关闭复选框。
(3)可以看到项目文件多了刚才的扩展库。

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(4)

 

 上面的报错也解决了。

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(5)

可以看到我的项目并没有libs文件夹,在查找资料时候许多都是介绍有libs文件夹,如果大家有遇到的话那就执行这一步星号3
(3*)在出现错误的工程目录libs加入 android-support-v7-appcompat.jar,复制粘贴即可。


到这里,如果你成功解决,没有报错信息了,而且可以运行项目,那恭喜你!

(・。・)然鹅,它还是出现另一个错误!ԅ(¯㉨¯ԅ)。
这时候开启下个解决方法。

出错二:android.support.v4.app.TaskStackBuilder$SupportParentable cannot be resolved. 解决方法

接着上一步骤还是没解决问题,报出另一个错误。

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(6)

 

 

可见,重写类出现错误,错误信息:The type android.support.v4.app.TaskStackBuilder$SupportParentable cannot be resolved. It is indirectly referenced from required .class files 。
它并没有正确加载基类,只能寻求其他方法了。

还有错误,error: Error retrieving parent for item: No resource found that matches the given name ‘Theme.AppCompat.Light’.等提示错误。

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(7) 


作为刚接触的我,经过不断搜寻,发现原来新建Android工程忽略了版本问题,Android SDK4.0以下版本设计风格与4.0以上存在差异,导入v4、v7还是不能解决问题。
因为现今版本的jar包位置已经改动,我们需要正确配置SDK API版本,具体采用SDK4.0以上,API14以上,正确具体步骤如图,按顺序操作:
(1)创建Android项目

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(8)

(2)填写项目名称和SDK版本选择(重要!)

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(9)

 

 (3)然后一直点Nest默认下一步,直到Finish,等待项目的创建。
如果跟下图一样运行测试程序成功,那就恭喜你成功啦!

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(10)

如果出现另一个错误:Failed to load D:Androidandroid-sdk-windowsbuild-tools29.0.3libdx.jar和Unknown error: Unable to build: the file dx.jar was not loaded from the SDK folder!

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(11)

 

 这个原因是项目所需的最低SDK/API比创建的ADT虚拟机的API高,所以会提示不兼容错误。
那么请继续转下一站解决办法。

 

出错三:the file dx.jar was not loaded from the SDK folder! 解决(最后一步!)

查看自己安装的Android版本,下面以我的安装为例,如图:

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(12)

 

 对应的找到build-tools的API 22版本:

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(13)

 

 然后再项目文件找到project.properties文件,添加下载安装的匹配的build-tools版本:

sdk.buildtools=22.0.1

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(14)

 

 到这里大功告成!可以看看第一个测试应用运行啦。

Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!插图(15)

 

 

开启Android学习的旅程!如果大家还遇到问题,可以留言评论,我会帮忙解决哦!

我的博客园:https://www.cnblogs.com/chenzhenhong/p/13456646.html
我的CSDN博客:Eclipse新建Android项目报错解决方案详细汇总

 

————————————-

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/Charzous/article/details/107870567
本站资源均源自网络,若涉及您的版权、知识产权或其他利益,请附上版权证明邮件告知。收到您的邮件后,我们将在72小时内删除。
若下载资源地址错误或链接跳转错误请联系站长。站长q:770044133。

» Eclipse开发Android项目报错解决方案详细教程,最新版一篇就够了!

发表评论

免登录下载网,提供全网最优质的资源集合!